Adding Groovy Support to Eclipse Mars 4.5

The short answer:

  1. Open Eclipse
  2. Select the menu: Help->Install new software…
  3. Click the Add… button
  4. Enter http://dist.springsource.org/snapshot/GRECLIPSE/e4.5/ for the name and URL
  5. Select groovy packages and install

The longer answer is that that since Pivotal Software has dropped funding for Groovy there is a bit of a transition period and things aren’t as easy to find as they used to be. I also no longer find using STS as beneficial since a quick install to get running was the goal and if I have to install Groovy support separately moving forward with STS too then why not use the standard Eclipse app?

Advertisements